Data Refresh issue with Copper Reporting

Incident Report for Copper

Resolved

The issue has been resolved by our provider. All customers should have up to date reporting data now.
Posted Apr 10, 2025 - 12:46 PDT

Investigating

Reporting data is not refreshing at the moment due to an upstream provider issue. Reports and dashboards are still available in Copper. Previously loaded data is visible in Copper Reporting.
Posted Apr 10, 2025 - 08:36 PDT
This incident affected: Reporting.