Custom Report data is delayed

Incident Report for Copper

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 14:01 PST

Update

We are continuing to investigate this issue.
Posted Feb 09, 2026 - 12:24 PST

Investigating

We are investigating issues with Custom Report data refreshing.

Custom Reports data is currently delayed, Custom Report data is accurate to Friday, February 6, and remains accessible at this time.
Posted Feb 09, 2026 - 10:11 PST
This incident affected: Custom Reports Builder.