Custom Report data is delayed

Incident Report for Copper

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 06:53 PST

Investigating

We are investigating issues with Custom Report data refreshing.

Custom Reports data is currently delayed, Custom Report data is accurate to Tuesday, February 17, and remains accessible at this time.
Posted Feb 18, 2026 - 16:28 PST
This incident affected: Custom Reports Builder.