Copper Website Issue

Incident Report for Copper

Resolved

This incident has been resolved.
Posted May 13, 2025 - 18:20 PDT

Update

We are continuing to monitor for any further issues.
Posted May 03, 2025 - 11:19 PDT

Monitoring

Copper website (copper.com) was unavailable for about an hour starting at 12 p.m EST. It has been restored and operational now.
Posted May 03, 2025 - 11:19 PDT