Amazon AWS Incident Impacting Copper

Incident Report for Copper

Resolved

AWS has resolved the issue.
Posted Oct 20, 2025 - 18:35 PDT

Update

AWS continues to have issues with several services.
Posted Oct 20, 2025 - 14:43 PDT

Update

AWS continues to have issues with several services.
Posted Oct 20, 2025 - 13:09 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:04 PDT

Investigating

Some customers might be experiencing degraded performance due to ongoing AWS Issues with several services.
You can see the AWS services status here: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 06:35 PDT
This incident affected: Google Sync, CRM for Gmail Chrome Extension, Marketing Tools, Mobile Applications, Reporting, Custom Reports Builder, Search Index, Integrations, Developer API, Rest API & Web Application, Help Center, Community, Workflow Automation, Forms Builder, Forms Submission, and Tracked Links in Emails.