Copper CRM for Gmail Chrome Extension Loading Issue
Incident Report for Copper
Resolved
We've confirmed that the update has fixed the extension loading issue. If you see further issues, please reach out to us at support@copper.com.
Posted 5 months ago. Mar 13, 2019 - 23:32 PDT
Monitoring
We've applied the fix and are monitoring recovery.
Posted 5 months ago. Mar 13, 2019 - 23:00 PDT
Update
We have diagnosed the underlying cause and are preparing a fix.
Posted 5 months ago. Mar 13, 2019 - 20:28 PDT
Identified
We've identified a compatibility issue between the latest version of Chrome (v73) that conflicts with our Copper CRM extension and are working on a fix.

A workaround is available for users by following the steps below:
1. Navigate to chrome://flags
2. Type “enable network service” into the search bar at the top
3. Select “Disabled” from the dropdown for “Enable network service” experiment
4. Click “RELAUNCH NOW” from the bottom bar that pops up after the above step
5. You should be able to load and log into the Chrome Extension now
Posted 5 months ago. Mar 13, 2019 - 17:18 PDT
This incident affected: CRM for Gmail Chrome Extension.