"Deceptive site ahead" error
Incident Report for Copper
Resolved
This issue has been resolved.
Posted Oct 19, 2021 - 09:42 PDT
Investigating
We are aware that some users have received a red screen indicating "Deceptive site ahead" when accessing some parts of the web app. We are currently investigating the issue but rest assured Copper has not been Hacked or Phished. The issue seems limited to certain regions at this time.
Posted Oct 19, 2021 - 09:11 PDT