Copper Services affected by Google Issues

Incident Report for Copper

Resolved

These issues have been resolved.
Posted Jun 12, 2025 - 21:53 PDT

Monitoring

It appears that Google issues have been resolved.
Posted Jun 12, 2025 - 18:40 PDT

Update

A lot of Google Services are still down. Here is google status page : https://status.cloud.google.com/
Posted Jun 12, 2025 - 13:43 PDT

Investigating

Some of the Copper Services might be affected due to Google having issues with their services.
Posted Jun 12, 2025 - 12:17 PDT
This incident affected: Google Sync, CRM for Gmail Chrome Extension, Marketing Tools, Mobile Applications, Reporting, Custom Reports Builder, Search Index, Integrations, Developer API, Rest API & Web Application, Help Center, Community, Workflow Automation, Forms Builder, Forms Submission, and Tracked Links in Emails.