Chrome Extension Outage
Incident Report for Copper
Resolved
We have released a fix that has resolved the issue.
Posted Apr 22, 2021 - 17:39 PDT
Investigating
A recent update to Chrome(Version 90) is preventing our extension from connecting. We are currently investigating.
Posted Apr 22, 2021 - 12:45 PDT
This incident affected: CRM for Gmail Chrome Extension.