We are investigating an issue with the Google Sheets Add-on resulting in difficulty Importing Data

Incident Report for Copper

Resolved

All issues are now resolved and all components are operational. If you still experience an issue after removing and re-installing the Chrome Extension or Google Sheets Add-on, please contact the Copper Support Team.
Posted Jun 15, 2026 - 13:11 PDT

Monitoring

Google has resolved the unverified issue causing some users to have trouble accessing accepting Google Permissions and accessing the Chrome Extension.

We are investigating a persisting issue with the Copper Google Sheets Add-on resulting in some users unable to Import Data.
Posted Jun 13, 2026 - 22:02 PDT

Update

We have identified a recent Google Security update is preventing some users from accepting Google Permissions.
Posted Jun 11, 2026 - 10:47 PDT

Update

We have identified a recent Google Security update is preventing some users from accepting Google Permissions.
Posted Jun 09, 2026 - 14:17 PDT

Identified

We've identified the issue and we are working on the solution.
Posted Jun 09, 2026 - 08:45 PDT
This incident affected: Google Sync, CRM for Gmail Chrome Extension, Marketing Tools, Mobile Applications, Reporting, Custom Reports Builder, Search Index, Integrations, Developer API, Rest API & Web Application, Help Center, Workflow Automation, Forms Builder, Forms Submission, and Tracked Links in Emails.