www.copper.com Issues

Incident Report for Copper

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 08:03 PDT

Investigating

Some customers are not able to get to www.copper.com at the moment. We are investigating the issue.
Please note that Copper Application is working fine.
Posted Oct 28, 2025 - 07:27 PDT
This incident affected: Help Center and Community.